如何解决ALTER TABLE causes auto_increment resequencing ?

分类:工作记,问题集 | 作者:凹凸曼 | 发表于2015/10/31

最近,升级Discuz! X2.5 到 Discuz! X3.2 升级过程中遇到如下错误:

升级SQL语句:

升级表 pre_home_notification 出错,请手工执行以下升级语句后,再重新运行本升级程序:
ALTER TABLE pre_home_notification CHANGE `id` `id` mediumint(8) unsigned NOT NULL AUTO_INCREMEN
Error: ALTER TABLE causes auto_increment resequencing, resulting in duplicate entry ‘16777215’ for key ‘PRIMARY’
Errno.: 1062

按照官网的手动的方法执行一样报错。

接下来我进入数据库查看 此表的结构 ,就明白了。

centos升级完firefox出现闪退

分类:Linux | 作者:凹凸曼 | 发表于2014/11/05

最近测试页面觉得firefox版本太老了,是时候升级一下firefox了,系统:centos6.5
update 完,点firefox 木有任何提示就退。。。 这自动升级都不考虑依赖包吗?

直接命令下运行,发现错误如下:

/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/firefox/libxul.so: undefined symbol: gdk_window_get_visual

看来是gdk库版本问题,木有办法 ,算了全部update一下,就解决了。。。

个人觉得软件升级应该有提示一下:需要那些重要的依赖包或者自动升级时候把相关依赖包考虑进去

Deprecated: Function set_magic_quotes_runtime() is deprecated 版本问题?

分类:PHP,问题集 | 作者:凹凸曼 | 发表于2011/06/20

刚刚把本地的环境 PHP v5.2.2 版本 升级到了PHP v5.3.2

把开发过的项目重新运行 就发生错误!

说明版本问题了!!

Deprecated: Function set_magic_quotes_runtime() is deprecated in F:\wwwroot\mongodb\manage\app.php on line 13

官方提供的解决办法:

升级Nginx 0.8.14 到1.0.4 (二)

分类:Nginx | 作者:凹凸曼 | 发表于2011/06/13 2条评论

Nginx1.0.0 正式版本已经出来一段时间了
今天终于有时间对nginx服务器的进行了无缝升级了一下

一、下载、解压
wget http://nginx.org/download/nginx-1.0.4.tar.gz
tar zxvf nginx-1.0.4.tar.gz

二、查看已经安装的模块

升级Nginx 0.7.61到0.8.14

分类:Nginx | 作者:凹凸曼 | 发表于2011/04/11

Nginx升级方法,下面将详细列出!
tar zxvf nginx-0.8.14.tar.gz
cd nginx-0.8.14