DZ安装插件报错:Cannot use string offset as an array

分类:PHP,问题集 | 作者:凹凸曼 | 发表于2017/10/20

discuz3.4安装插件报错:Cannot use string offset as an array

环境:PHP7.1以上

解决办法:

文件source/function/function_plugin.php

搜索:foreach($vars as $key => $var) {

后面插入代码

 if(!$_G['cache']['pluginlanguage_system'])
 $_G['cache']['pluginlanguage_system']=array();
修改后如下图所示:
1111

 

提交到gitee:https://gitee.com/apoyl/DiscuzX/commit/73ebcc8c05fed33294be06aaceede7dcd94dfae6

本文出自 “凹凸曼” 博客,请务必保留此出处 http://www.apoyl.com/?p=2172

Tag:

日志信息 »

该日志于2017-10-20 16:57由 凹凸曼 发表在PHP, 问题集分类下, 你可以发表评论。除了可以将这个日志以保留源地址及作者的情况下引用到你的网站或博客,还可以通过RSS 2.0订阅这个日志的所有评论。

目前盖楼 (0)层:

发表评论 »

« »